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Assigning Access Levels 
Before users can attempt to manage the scheduler for your organisation they must be assigned the 

correct access levels. Follow the steps below to assign the access levels: 

Step 1. Select Operations > People > Personnel. The Personnel screen is displayed. 

Step 2. Filter the Personnel screen according to your requirements. 

 Enter filter criteria in the text-box and click [Filter]. 

 Select a value from the Department drop-down list to view personnel located in a 

particular department. 

 Select a value from the Base drop-down list to view personnel located in a particular 

base location. 

 Select the Show In-Active tick box to include personnel that are no longer active in 

the system. This includes personnel which have ceased employment with your 

organisation. 

Step 3. Click [Details] to view detailed personnel information. If you do not have the required 

access level to view personnel details, a warning is displayed. 

 
Step 4. Select ‘Access Levels’ from the Personnel Profile pane. 

 
Step 5. Click [Edit]. 
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Step 6. Select the applicable access levels in the ‘Scheduling’ group. 

 

Access Level Description  

Scheduling > 

Administration > Modify All 
Allows users to setup the Scheduling module including task 

types, schedule notifications and custom fields. This access 

enables access to Manage > Setup… > Scheduling. 

Scheduling > Scheduler Role 

> Modify Selection 

Allows users to add, edit and delete tasks in the Scheduling 

module for a specific base. Users with this access are able to 

change all settings for the task, including resource requirements, 

notification rules and task details. 

Scheduling > Scheduler Role 

> Modify All 

Allows users to add, edit and delete tasks in the Scheduling 

module for all bases. Users with this access are able to change all 

settings for the task, including resource requirements, 

notification rules and task details. 

Scheduling > Tasking Role > 

View Selection 

Allows users to view tasks for a specific base, but prevents the 

addition and editing of data for all fields. 

Scheduling > Tasking Role > 

View All 

Allows users to view tasks for all bases, but prevents the addition 

and editing of data for all fields. 

Scheduling > Tasking Role > 

Modify Selection 

Allows users to add and edit tasks and assign resources for a 

specific base, but prevents changes to task resource 

requirements. 

Scheduling > Tasking Role > 

Modify All 

Allows users to add and edit tasks and assign resources for all 

bases, but prevents changes to task resource requirements. 

 

Step 7. Click [OK]. 
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Setting Up Global Settings 

Setup Scheduler Options 

Step 1. Select Manage > Setup… > Scheduling. The Scheduling Setup screen is displayed. 

 
Step 2. Select the name(s) of the primary scheduler(s) from the Chief Scheduler(s) drop-down list. 

Step 3. Select the default time zone for your organisation from the Default Timezone drop-down 

list. 

Step 4. Enter the start and end time for a working day in the Start of Working Day and End of 

Working Day fields. 

Step 5. Click [Save Changes]. 

Setup Department Roles 

Department roles allow endorsements to be segregated into different groups for each department 

in the Air Maestro system. Defining endorsements by department roles allows the scheduling 

module to filter personnel based on certain resource requirements in addition to tracking which 

pilots are endorsed to perform what role. 

For example, John Smith has been given the F14 endorsement for the PIC department role and the 

B412 endorsement for the SIC department role (see below). 

This ensures that John Smith only appears as a resource in the scheduler for tasks that require pilots 

who are endorsed on the PIC role for the F14 and A109 aircraft type. 
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Step 1. Select Manage > Setup… > Scheduling. The Scheduling Setup screen is displayed. The 

Department Roles pane is displayed below the Scheduling Options pane. 

 
Step 2. Click [Add new record] to define a new department role. 

 
Step 3. Select a department from the Department drop-down list. 

 

 

To create additional departments, select Manage > Setup…> AM Data. Next, select 

the ‘Departments’ option from the drop-down list and click [Add Record]. Complete 

the new department details and click [  ] to save the new department. 

 

Step 4. Enter an applicable department role name in the Role text box. 

 
Step 5. Click [  ] to confirm the new department role. 

 
 

 

To edit an existing department role, click [  ] for the applicable department role, 

make the required changes and click [  ] to confirm. 
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Setup Sunrise/Sunset Options 

Air Maestro’s Scheduling module includes a feature to calculate the sunrise and sunset times at each 

base location for scheduled tasks. 

Step 1. Select Manage > Setup… > Scheduling. The Scheduling Setup screen is displayed. The 

Sunrise/Sunset Options pane is displayed adjacent to the Scheduling Options pane. 

Step 2. Select the Display Sunrise/Sunset Times in Scheduler option to view the sunrise and 

sunset times at the base corresponding with the scheduled task. 

Step 3. Select the applicable option from the Zenith drop-down list. 

Step 4. Enter the required offset for the sunrise and sunset times in the Apply offset of text box. 

Step 5. Select the applicable rounding options for the sunrise and sunset times in the then round 

and to the nearest text boxes. 

 
Step 6. Click [Save Changes]. 

 

 

To calculate the sunrise/sunset times for a base location, ensure the GPS co-

ordinates and the time zone are set for the location. Set the GPS co-ordinates via 

Operations > Locations > All Locations > Location Details. Set the time zone via 

Operations > Locations > Bases > Base Details. 
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Managing Task Statuses 

Create Task Status 

When a new task status is created, it must contain a unique identifiable name. The name assigned to 

the task status is displayed in the schedule. 

Step 1. Select Manage > Setup… > Scheduling. The Scheduling Setup screen is displayed. 

Step 2. Select the Task Status tab. 

 
Step 3. Click [Add New Task Status]. A new row is displayed in the Task Status grid. 

 
Step 4. Enter a unique identifier for the task status in the Task Status text box. 

Step 5. Use the colour swatches to set a background colour for the task status. 

Step 6. Select the Active tick box if this task status is to be available immediate for scheduling. 

Step 7. Click Apply [  ]. The new task status is displayed in the Task Status grid. 
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Managing Task Types 
Task types are used in the Scheduling module to organise common company tasks. Each task type 

can be associated with a set of resource requirements (aircraft and personnel), notification options 

and custom fields. An instance of a task type with associated resource requirements, notification 

rules and custom fields is then created in the scheduler. 

It is important that the task types are configured according to the organisational requirements, 

before using the Scheduling module. 

Create Task Type 

When a new task type is created, it must contain a unique identifiable name. The name assigned to 

the task type is displayed in the scheduler. 

Step 1. Select Manage > Setup… > Scheduling. The Scheduling Setup screen is displayed. 

Step 2. Select the Task Types tab. 

 
Step 3. Click [Add New Task Type]. A new row is displayed in the Task Types grid. 

 
Step 4. Enter a unique identifier for the task in the Task Type text box. 

Step 5. Select the Don’t allow resources to multitask option to prevent resources being assigned 

to this task if they are already assigned to an existing task during the same period. 

Step 6. Select the Ensure resources are rostered option to ensure that resources being assigned 

to this task are rostered for duty on the associated day. 

Step 7. Select the Link to sunrise times option to link the task start time to the calculated sunrise 

time of the base location. 
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Step 8. Select the Link to sunset times option to link the task end time to the calculated sunset 

time of the base location. 

 

 

The Link to sunrise times and Link to sunset times options are only available if 

the Display Sunrise/Sunset Times in Scheduler option is enabled via Manage > 

Setup… > Scheduling > Global Settings. 

 

Step 9. Use the colour swatches to set a text and background colour for the task type. 

Step 10. Select the Active tick box if this task type is to be available immediate for scheduling. 

Step 11. Click Apply [  ]. The new task type is displayed in the task type grid. 
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Setup Aircraft Resource Requirements 

Air Maestro allows you to associate the required resource requirements for each task type. 

For example, a ‘HEMS’ task type may require an Aircraft, Pilot in Command, Co-Pilot, and Flight 

Nurse as resources. 

When you schedule the task type, the system flags whether the task type meets the minimum 

resource requirements. 

Step 1. Select Manage > Setup… > Scheduling. The Scheduling Setup screen is displayed. 

Step 2. Select the tab corresponding with the required task type. The Default Resourcing 

Requirements pane is displayed. 

 
Step 3. Click [Add Resource Requirement] 

 
Step 4. Enter the name of the resource in the Resource Name field. For example, Aircraft, 

Secondary Aircraft, Simulator etc. 

Step 5. Select the ‘Aircraft’ resource type from the Type drop-down list. The resource options are 

updated depending on the option selected. 

Step 6. Select the total number of this resource type required for the task type from the # 

Required drop-down list. 
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Step 7. Select the maximum number of this resource type required for the task type from the Max. 

Resources drop-down list. 

 
Step 8. Click [modify] corresponding with the Type Restriction field, to restrict the aircraft 

resource to a particular endorsement. If the aircraft resource does not require a specific 

endorsement proceed to Step 11. 

 
Step 9. Enter the first characters for the required endorsement code and select the required code 

from the drop-down list. 

 
Step 10. Click [update] after all required type restrictions are selected. 

 
Step 11. Click [modify] corresponding with the Recency Requirements field, to ensure the aircraft 

resource meets particular recency requirements. If the aircraft resource does not require 

any specific recency requirements proceed to Step 14. 

 
Step 12. Enter the first characters for the required aircraft recency item and select the required 

recency from the drop-down list. 
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Step 13. Click [update] after all required recency items are selected. 

 
Step 14. Click [Insert] to save the resource. 

 

Setup Personnel Resource Requirements 

Step 1. Select Manage > Setup… > Scheduling. The Scheduling Setup screen is displayed. 

Step 2. Select the tab corresponding with the required task type. The Default Resourcing 

Requirements pane is displayed. 

 
Step 3. Click [Add Resource Requirement] 

 
Step 4. Enter the name of the resource in the Resource Name field. For example, Captain, First 

Officer, Flight Attendant, Doctor, Flight Nurse, Paramedic etc. 

Step 5. Select the ‘Personnel’ resource type from the Type drop-down list. The resource options 

are updated depending on the option selected. 
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Step 6. Select the total number of this resource type required for the task type from the # 

Required drop-down list. 

Step 7. Select the maximum number of this resource type required for the task type from the Max. 

Resources drop-down list. 

 
Step 8. Click [modify] corresponding with the Department field, to restrict the personnel resource 

to a particular department. If the personnel resource is not required from a specific 

department proceed to Step 11. 

 
Step 9. Enter the first characters for the required department and select the required department 

from the drop-down list. 

 
Step 10. Click [update] after all required department restrictions are selected. 

 
Step 11. Click [modify] corresponding with the Endorsement field, to restrict the personnel 

resource to a particular endorsement. If the personnel resource does not require a specific 

endorsement proceed to Step 14. 
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Step 12. Enter the first characters for the required endorsement and select the required 

endorsement from the drop-down list. 

 
Step 13. Click [update] after all required endorsement restrictions are selected. 

 
Step 14. Click [modify] corresponding with the Recency Requirements field, to ensure the 

personnel resource meets particular recency requirements. If the personnel resource does 

not require any specific recency requirements proceed to Step 17. 

 
Step 15. Enter the first characters for the required personnel recency item and select the required 

recency from the drop-down list. 

 
Step 16. Click [update] after all required recency items are selected. 

 
Step 17. Click [modify] corresponding with the Required Experience field, to restrict the personnel 

resource to a particular experience requirement. If the personnel resource does not 
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require a specific endorsement proceed to Step 22. 

 
Step 18. Enter any character in the Required Experience drop-down list to display the applicable 

options. 

 
Step 19. Select the experience requirements for this personnel resource. 

 
Step 20. Complete the minimum experience requirements in each selected field according to the 

options available. 

 

Option Description  

Total Experience Enter the minimum total flying hours required by personnel in 

order to fulfil this task. 

Total Hrs. On Type Enter the minimum total flying hours on the associated aircraft 

type required by personnel in order to fulfil this task. 

Cmd. Hrs. Enter the minimum ‘in command’ flying hours required by 

personnel in order to fulfil this task. 

Cmd. Hrs. on Type Enter the minimum ‘in command’ flying hours on the associated 

aircraft type required by personnel in order to fulfil this task. 

Task Hrs. > Enter the minimum flying hours on the selected task (Charter, 

Firefighting etc.) required by personnel in order to fulfil this task. 

Note that the task types are configurable for each organisation 

via the Manage > Setup > Timesheets option and by selecting the 

Flight Tasks tab. 

Task Hrs. On Type Enter the minimum flying hours on the selected task on the 

associated aircraft type required by personnel in order to fulfil 

this task. 
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Step 21. Click [update] after all required experience restrictions are completed. 

 
Step 22. Click [Insert] to save the resource. 

 
Step 23. Continue adding additional personnel resources to the task type by following Steps 3-22. 

Setup Notification Requirements 

SMS and email notifications can be setup for each task type when an instance of the task type is 

created, modified, delete and/or is scheduled but one or more resources do not meet the 

requirements. 

Step 1. Select Manage > Setup… > Scheduling. The Scheduling Setup screen is displayed. 

Step 2. Select the tab corresponding with the required task type. The Default Scheduling 

Notifications pane is displayed below the Default Resourcing Requirements. 

 
Step 3. Enter the required notification window for the task type in the Notification Window field. 

Enter the number of hours before the task type is scheduled to begin, where the email 

alert should be generated. The notification is only sent if the task type does not meet one 

or more of the resource requirements. 

 
Step 4. Select the personnel that must be notified for this task type if the task requirements are 

not met from the Personnel to notify via Email drop-down list. 



Air Maestro Training Guide – Scheduling Module  Page | 19 

Step 5. Click [Save Changes]. 

 

Setup Custom Fields 

Step 1. Select Manage > Setup… > Scheduling. The Scheduling Setup screen is displayed. 

Step 2. Select the tab corresponding with the required task type. 

Step 3. Scroll to the Custom Fields pane. 

Step 4. Click [Add New Field]. 

 

 

A ‘Group’ custom field is recommended when setting up new fields for the tab. 

Adding custom fields to a group allows the user to control how the custom fields are 

displayed in the task. 

 

Step 5. Select ‘Group’ from the Control Type drop-down list. 

Step 6. Enter the control name in the Control Name text box. This name is a unique identifier 

used to store the custom field in the database. Special characters such as ‘?’ and ‘%’ etc are 

not accepted. 

Step 7. Enter the control label in the Control Label text box. This label is displayed in task. 

Step 8. Select the Border tick box to include a border around the custom field. 

Step 9. Select the Display Label tick box to display the label entered in the Control Label text box 

in the task. 

 
Step 10. Complete the Options pane for the custom field as required. 

Option Description  

Display Mode Select the display mode for the group field. The ‘Flow’ display 

mode attempts to fit all the custom fields as close together and 

as neatly as possible. The ‘Table’ display mode displays each 

custom field one after another depending on the direction. 

Direction Select the direction in which the custom fields are displayed. 

Number of Columns Select the number of columns that are contained within this 

group. 

Label Width Enter the width of each field label within this group. 

Group Width Enter the width of the entire group. 

Alignment Select the required alignment of fields within this group. 

Display Options Select the display option for the group field. 
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Step 11. Click [Insert]. The Custom Fields grid is update with the new custom field. 

 
Step 12. Click [  ] associated to group custom fields or use the Hierarchy drop-down list to 

navigate to the group custom field. All the custom fields that reside inside are displayed in 

the Custom Fields grid. 

Step 13. Click [Add New Field] to add a custom field to the group custom field. 

Step 14. Select the required field type from the Control Type drop-down list. 

Option Description  

Aircraft Displays a drop-down list of every aircraft within the system. 

Autonumber Displays an automatically generated number starting from a base 

number and prefix. 

Calculated Field Displays a calculated value based on a formula involving other 

custom fields. For example, you may create an ‘Age’ calculated 

field, which outputs a numeric value based on an entry in a ‘Date 

of Birth’ custom field. 

Checkbox Displays a tick box that enables the user to select from true/false 

or yes/no options. 

Checkbox List Displays multiple tick boxes that enable the user to select one or 

more items. 

Cumulative Time Displays a text box which enables the user to enter an amount of 

time. 

Date Control Displays a picker that enables the user to select a date. 

Date Time Displays a picker that enables the user to select a date and time. 

Drop-Down List Displays a predefined list that enables the user to select a single 

item from the list. 

Group Groups multiple custom fields under a single heading. 

Label Displays a line of text. 

Numeric Displays a text box which enables the user to enter numerical 

data. 

Personnel Displays a drop-down list of all personnel within the system and 

when a user is selected, further information is displayed about 

the selected user (Contact Details, Company Details, Pilot Details 

or Crewmen Details). 

Radio Button List Displays multiple radio buttons that enable the user to select a 

mutually exclusive option. 

Text Displays a text box which enables the user to enter text data. 

Time Displays a text box which enables the user to enter time data. 

Upload Displays the upload control allowing users to upload files. 

 

  



Air Maestro Training Guide – Scheduling Module  Page | 21 

Step 15. Complete the custom field options with the required settings. 

Option Description  

Control Name Enter the unique identifier for the custom field in the Control 

Name text box. This name is used to store the custom field in the 

database. Special characters such as (? % etc.) are not accepted. 

Control Label Enter the display name for the custom field in the Control Label 

text box. For example, you may enter a more descriptive name 

than that entered in the Control Name field as this field is 

displayed in the interface. 

Border Select the Border tick box to include a border around the field. 

Display Label Select the Display Label tick box to include the label entered in 

the Control Label text box for the field. 

 

Step 16. Complete the Options pane for the custom field as required. The options vary according to 

the selected custom field. 

 

For example, for the ‘Drop-Down List’ control type you must specify if the custom field is 

required, the different list items, and if the custom field is always displayed. For the ‘Text’ 

control type you must specify if the custom field is required, if a multi-line text box is 

required, the dimensions of the text box, and if the custom field is always displayed. 

 

 

The Display Options field allows you to specify when the field must be displayed. 

The default is ‘Always’, but if you click the ‘Always’ text a dialog box is displayed 

which allows you to set the view rules for the field. 

For example, if you had a field for ‘Delays’ you may wish to display a ‘Description’ 

text box only when the ‘Delays’ field is selected. 

 

Step 17. Click [Insert]. The custom field grid is updated with the new custom field. 

 
 

 

A preview of the custom field is available in the Preview pane. To modify the field, 

click [  ], edit the required options and click [Update]. 

 

Step 18. Repeat Steps 13-18 to add additional custom fields within the same group custom field. 

Step 19. To add additional custom fields to another group custom field, click [  ] associated to 

group custom field or use the Hierarchy drop-down list to navigate to the group custom 

field. All the custom fields that reside inside are displayed in the Custom Fields grid. 

Step 20. Repeat Steps 13-18 to additional custom fields to the selected group custom field. 

Step 21. Select ‘root’ from the Hierarchy drop-down list to navigate out of any group custom field 

and back to the original Custom Field grid to add additional custom fields outside of the 

first group custom field. 
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Modify Task Types 

Step 1. Select Manage > Setup… > Scheduling. The Scheduling Setup screen is displayed. 

Step 2. Select the Task Types tab. 

 
Step 3. Click Edit [  ] corresponding with the required task type. 

Step 4. Edit the required information. 

Step 5. Click Update [  ]. The Task Types grid is updated with the changes. 

Step 6. Select the tab corresponding with the required task type. 

 
Step 7. Edit the required resource requirements, notification options or custom fields. 
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Disable Task Types 

Step 8. Select Manage > Setup… > Scheduling. The Scheduling Setup screen is displayed. 

Step 9. Select the Task Types tab. 

 
Step 10. Click Edit [  ] corresponding with the required task type. 

Step 11. Unselect the Active tick box. 

Step 12. Click Update [  ]. The Task Types grid is updated with the changes. 
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Scheduling Fundamentals 
Air Maestro’s scheduling module allows users to create compliant schedules in an online 

environment. Schedules created in Air Maestro can be verified to ensure they meet the work 

practice and resource requirements as setup by your organisation. Furthermore, the notification 

tool allows you to automatically alert assigned personnel if a task is not allocated or does not meet 

the task requirements. 

The Filters 

There are a number of filters users can select to view schedules in the desired format. The available 

filters are linked to the view type and may not be available in each view type. 

 

Filter Description  

Task Type Use the Task Type filter to view selected task types in the 

schedule. 

Group By Use the Group By filter to group the scheduled tasks by Base, 

Personnel, Aircraft, Task Type or Task. 

Base Use the Base filter to view selected base locations in the 

schedule. 

Department Use the Department filter to view selected base locations in the 

schedule. 

Zoom Use the Zoom filter to view the scheduled tasks for a single day, 

three days, week or fortnight. This filter is only available in the 

Timeline view. 

Display Exact Times Use the Display Exact Times option to display the scheduled 

tasks according to their start and end times in the schedule. This 

filter is only available in the Timeline view. 

Switch Orientation This option is only available in the Week and Rolling Week views 

when grouping is applied in the Group By filter. 

Begin Validation Click [Begin Validation] to validate the compliance of all tasks 

listed in the current view. 
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The Views 

There are five views users can select from when viewing the scheduler. 

 

Filter Description  

Day Use the Day view to view a single day in the schedule. Times are 

listed vertically. 

Week Use the Week view to view a single week in the schedule. Times 

are listed vertically and days of the week are displayed 

horizontally. 

Rolling Week Use the Rolling Week view to view a single week in the schedule, 

commencing from today’s date. Times are listed vertically and 

days of the week are displayed horizontally. 

Month Use the Month view to view a single month in the schedule. 

Timeline Use the Timeline view to view scheduled tasks in a selected time 

period in a Gantt Chart format. Combine the Timeline view with 

the Group By filter options, to display scheduled tasks by Base, 

Personnel, Aircraft, Task Type or Task. 
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Tool Tip Attributes 

Scheduled tasks can be hovered over to display further information about the scheduled task. In the 

example below, the task is titled ‘Hospital Transfer’. When hovered over the details of the task are 

displayed. 

 

Filter Description  

Task Type and Name The first section of the tool tip, displays the task type (HEMS 

Flight) and task name (Hospital Transfer). 

Date The Date field displays the date of the scheduled task and the 

corresponding day of the week. 

Time The Time field displays the start and end time of the scheduled 

task. 

Duration The Duration field displays the total duration of the scheduled 

task, automatically calculated based on the start and end time. 

Flight time The Flight Time field displays the total flight time associated with 

the scheduled task. 

Route The Route field displays the route associated with the scheduled 

task.  

Description The Description field displays the detail of the task as entered in 

the Description text box on the Task Details tab. 

Resource requirements The last section of the tool tip, displays the resources required 

for the task type and if applicable the names of the resources 

assigned to that task. In the example above, there are two 

resource requirements (Aircraft and PIC) and both are 

unallocated. 

Custom Fields If custom fields have been enabled for the task type and 

completed, the hover also displays the completed details. 
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Scheduled Task Compliance Icons 

Can icon indicates the compliance status with work practices and recency requirements for 

scheduled tasks. The following icons are used to indicate task compliance. 

Icon Description  

No Icon Normal view of a scheduled task. Indicates that all resource 

requirements are allocated and there are no conflicts with 

overlapping tasks, rostered data etc. 

 

A blue icon in the upper right hand corner indicates a notice for 

the scheduled task. 

 

A notice could be triggered by one of the following: 

 

 An aircraft or personnel has been assigned as a resource 

multiple times for the same task 

 An aircraft or personnel has been assigned as a resource 

for the task, but they are not currently located at the task 

base 

 A personnel resource assigned to the task has a work 

practice control on the task date in the caution threshold 

 

A red icon in the upper right hand corner indicates a critical alert 

for the scheduled task. 

 

A critical alert could be triggered by one of the following: 

 

 A required aircraft or personnel resource has not been 

assigned to the task 

 An assigned aircraft or personnel resource does not meet 

the resource requirements for the task 

 An assigned aircraft or personnel resource has an 

overlapping task (and it is a requirement of the task that 

resources cannot overlap) 

 An aircraft resource assigned to the task is offline 

 A personnel resource assigned to the task is on leave 

 A personnel resource assigned to the task is not rostered 

on duty (or standby) on the task date (and it is a 

requirement of the task that resources are rostered) 

 A personnel resource assigned to the task has a work 

practice control on the task date in the critical threshold 

 A mandatory custom field has not been completed 
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Viewing the Scheduler 
Step 1. Select Operations > Scheduling > Scheduler. The Scheduler screen is displayed. 

Step 2. Modify the filters and views to suit your requirements. 

Step 3. Select the required date period using the date picker. 

 
 

The Scheduler for the selected period is displayed. 

Step 4. Hover on a scheduled task to display more information for that task. The tool tip is 

displayed. 

  
 

If there are any unallocated resources for this task, they are highlighted by the 

‘Unallocated’ red text. An icon indicates the compliance status with work practices and 

recency requirements for this task. 
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Creating Tasks 
Step 1. Select Operations > Scheduling > Scheduler. The Scheduler screen is displayed. 

Step 2. Modify the filters and views to suit your requirements. 

Step 3. Select the required date period using the date picker. 

 
 

The Scheduler for the selected period is displayed. 

Step 4. Select the preferred view for the selected date period. In the example below, the Timeline 

view is selected with a Single Day zoom and is grouping the tasks by Aircraft. 

 
Step 5. Double-click on the required date/time in the scheduler to create a new task. The Create 

Task dialog box is displayed. 
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Step 6. Complete the fields on the Task Details tab. 

 

Field Description  

Name Enter the task name in the Name field. 

Type Select the task type from the Type drop-down list. 

Date Edit the task date if required. 

Base(s) Select the base(s) related to the task. 

All Day Task Select the All Day Task option if the task spans the entire day. 

Alternatively, unselect the All Day Task option to enter a specific 

start and end time for the task. If entering start and end times for 

the task, you have the option to link the start and end times to 

the sunrise and/or sunset times for the base location. This option 

is only available if the Display Sunrise/Sunset Times in 

Scheduler option is enabled via Manage > Setup > Scheduling > 

Global Settings. 

Flight Hour(s) Enter the total day and night flight hours related to this task if 

applicable. 

Route Enter the route for the task if the task involves a flight. 

Alternatively, if the task consists of a number of legs, complete 

the Leg Details tab with the leg information, which will 

automatically update the Route field on this tab. 

Description Enter a description for the task. 
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Step 7. Select the Resources tab. The required resources for the task type are displayed as set in 

the task type setup. 

 
Step 8. Assign the required resources to the task by clicking on the Not Allocated! button. The 

Select Resource dialog box is displayed. 

Step 9. Select the required resource from the Name drop-down list for personnel and the 

Registration drop-down list for aircraft. Further information about the selected resource is 

displayed. 

 

 

Only resources matching the task resource requirements (endorsements, recency, 

departments etc.) are displayed in the drop down list. Resources not meeting the 

resource requirements can be selected by typing the resource name into the drop 

down list. 

 

Step 10. Click [Set Resource] 

Step 11. Select the Leg Details tab if legs are required for the task. Alternatively, if legs are not 

required proceed to Step 13. 

 

 

The Leg Details tab is only displayed if the ‘Track Flight Leg Data’ option is 

selected in Manage > Setup… > Flight Records. 

 

Step 12. Complete the fields on the Leg Details tab. 

Field Description  

Planned Departure – Time Enter the expected departure time for each leg. 

Planned Departure – 

Location 

Enter the expected departure location for each leg. This field is 

linked to the locations register and detects previously entered 

locations. If the departure location is not in the list, you can enter 

a new location in the text box. 

Planned Arrival –Time Enter the expected arrival time for each leg. 

Planned Arrival – Location Enter the expected arrival location for each leg. This field is linked 

to the locations register and detects previously entered locations. 

If the arrival location is not in the list, you can enter a new 

location in the text box. 
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Length This field is automatically calculated based on the time entered in 

the Planned Departure – Time and Planned Arrival – Time 

fields for each leg. 

Route Summary This field is automatically populated based on the Planned 

Departure – Location and Planned Arrival – Location fields for 

each leg. 

Update Route and Flight 

Hours From Legs 

Select this option to automatically update the Route and Flight 

Hours fields on the Task Details tab. 

Total This field is automatically populated based on the total of all the 

Length fields. 

 

Step 13. Select the Recurrence tab. 

 

 

If the task occurs only once, do not complete the Recurrence tab and proceed 

to Step 16. 

 

Step 14. Complete the fields on the Recurrence tab. 

Field Description  

Start Date Enter the start date of the task. 

Frequency Select the frequency of the task. 

 

Options include: 

 Hourly 

 Daily 

 Weekly 

 Monthly 

 Yearly 

 

Additional options are presented based on your selection. 

 

For example, if you select the daily option, you can specify 

whether the task occurs every weekday or at set intervals. 

End Date Enter the end date of the task. If the task occurs indefinitely, 

select the ‘No end date’ option. Otherwise, specify an end date or 

end the task after a set number of iterations. 

 

Step 15. Click [Create Recurrence]. The new recurrence rule is displayed in the Recurrence Rules 

pane. 

Step 16. Select the Notifications tab. The Default Schedule Notifications settings for the task 

type are displayed. 
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Step 17. Enter the required notification window for the task in the Notification Window field. Enter 

the number of hours before the task is scheduled to begin, where the email alert should be 

generated. The notification is only sent if the task does not meeting one or more of the 

resource requirements. 

Step 18. Select the time zone corresponding with the location of the task. 

Step 19. Select the personnel that must be notified for this task if the task requirements are not met 

from the Personnel to notify via Email drop-down list. 

Step 20. Select the Review & Save tab. The Additional Information (if applicable) and Resource 

Validation panes are displayed. 

Step 21. Review the Additional Information pane. This pane contains the list of required custom 

fields contained on the Additional Information tab which are incomplete. 

Step 22. Review the Resource Validation – Resources pane. Click the resource name to display the 

resource details (Roster Data, Recency Information, Experience, etc.). 

Step 23. Review the Resource Validation – Task Rules pane. 

Field Description  

Task Rules The Task Rules column validates whether the assigned 

resources met the resource requirements for the task. For 

example, if the task requires a pilot to be endorsed on the A109 

aircraft type and the assigned pilot does not have this 

endorsement, the  icon is displayed in Task Rule column. 

 

The  icon indicates that the assigned resources meet the 

resource requirements for the task. 

 

The  icon indicates that the assigned resources do not meet the 

resource requirements for the task. 

 

The  icon indicates that the assigned resource has not been 

toured to the base location associated with the task. 

 

To tour a resource from this view, click the icon in the Task Rules 

column to display the Tour Resources dialog box. 
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Step 24. Review the Resource Validation – Rostered pane. 

Field Description  

Rostered The Rostered column validates whether the assigned personnel 

resources have been rostered for ‘Duty’ or ‘Standby’ shifts. For 

aircraft resources, the Rostered column validates whether the 

assigned aircraft is online (based on the Aircraft Register). 

 

The  icon indicates that the assigned resources are rostered 

(personnel) or online (aircraft) for the duration of the task. 

 

The  icon indicates that the assigned resources are not 

rostered (personnel) or online (aircraft) for the duration of the 

task and the task requires the resources to be rostered. This 

option is specified via Manage > Setup… > Scheduling and by 

selecting the Task Types tab. Next, click the pencil icon 

corresponding with the task type and select the Ensure 

Resources are Rostered tick box. 

 

The  icon indicates that the assigned resources are not 

rostered (personnel) or online (aircraft) for the duration of the 

task but the task does not require the resources to be rostered. 

 

To roster a resource from this view, click the icon in the Rostered 

column to display the rostering dialog box. 
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Step 25. Review the Resource Validation – Overlap pane. 

Field Description  

Overlap The Overlap column validates whether the assigned resources 

have been assigned another task where the times overlap with 

the current task. 

 

The  icon indicates that the assigned resources do not have 

overlapping tasks. 

 

The  icon indicates that the assigned resources have 

overlapping tasks and this is not permitted in the Task Type 

setup. This option is specified via Manage > Setup… > 

Scheduling and by selecting the Task Types tab. Next, click the 

pencil icon corresponding with the task type and select the Don’t 

Allow Resources To Multi-Task tick box. 

 

The  icon indicates that the assigned resources are not 

rostered (personnel) or online (aircraft) for the duration of the 

task but the task does not require the resources to be rostered. 

 

Step 26. Review the Resource Validation – WP (Work Practice) pane. 

Field Description  

WP The WP column validates whether the assigned resources met 

the work practice rules associated with the rostered shift. 

 

The  icon indicates that the assigned resources are within the 

work practice limits. 

 

The  icon indicates that the assigned resources are 

approaching the work practice limits. 

 

The  icon indicates that the assigned resources have exceeded 

the work practice limits. 

 

Step 27. Click [Save]. The Create Task dialog box is closed and the task is displayed in the 

scheduler. 
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Changing Task Resources 
Step 1. Select Operations > Scheduling > Scheduler. The Scheduler Roster is displayed. 

Step 2. Right-click on the required task. 

Step 3. Click [Edit]. 

 
 

The Edit Task dialog box is displayed. 

 
 

 

If the task is linked to a series of tasks, you must select whether you wish to 

change the resources for the single task, change resources for the entire series 

of tasks or change resources  

 

Step 4. Select the Resources tab. 

Step 5. Modify the resources as required. 

Step 6. Select the Review & Save tab. 

 
Step 7. Review the Additional Information and Resource Validation panes for the task to ensure 

all required information is completed and there are no conflicts with resource 

requirements. 
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In the example below, the resource (Matthew Black) assigned to the PIC role has not been 

rostered for a corresponding duty, but is allocated to the task. 

 
Step 8. Click [Save] to confirm the task changes. 
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Editing Tasks 
The process of editing tasks varies depending on whether the task is linked to a series of tasks or is a 

single task. 

Edit a Single Task 

Step 1. Select Operations > Scheduling > Scheduler. The Scheduler screen is displayed. 

Step 2. Right-click on the required task. 

Step 3. Click [Edit]. 

 
 

The Edit Task dialog box is displayed. 

 
Step 4. Modify the required fields. 

Step 5. Select the Review & Save tab. 

 
Step 6. Review the Additional Information and Resource Validation panes for the task to ensure 

all required information is completed and there are no conflicts with resource 

requirements. 

 

In the example below, the resource (Matthew Black) assigned to the PIC role has not been 
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rostered for a corresponding duty, but is allocated to the task. 

 
Step 7. Click [Save] to confirm the task changes. 

Edit a Series of Tasks 

Step 1. Select Operations > Scheduling > Scheduler. The Scheduler screen is displayed. 

Step 2. Right-click on the required task. 

Step 3. Click [Edit]. 

 
 

The Edit a recurring appointment dialog box is displayed. 
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Step 4. Select the required option. 

Option Description  

Edit only this occurrence Select this option to only edit the selected task. 

Edit the series Select this option to edit the selected task and all other 

scheduled tasks linked to this series. 

 

For example, if you schedule a task with re-occurrence rules 

(Daily, Weekly etc), by selecting this option all tasks created by 

the re-occurrence rule for the selected task will also be edited. 

Edit appointments from 

this point on 

Select this option to edit the selected task and all other 

scheduled tasks linked to this series from the selected date. 

 

For example, if you schedule a task with re-occurrence rules 

(Daily, Weekly etc), by selecting this option all tasks created by 

the re-occurrence rule for the selected task will also be edited 

commencing on the scheduled date for the selected task. 

 

Step 5. Click [OK]. The Edit Task dialog box is displayed. 

Step 6. Modify the required fields. 

Step 7. Select the Review & Save tab. 

Step 8. Review the Additional Information and Resources Validation panes for the task to 

ensure all required information is completed and there are no conflicts with resource 

requirements. 

Step 9. Click [Save] to confirm the task changes. 
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Deleting Tasks 
The process of deleting tasks varies depending on whether the task is linked to a series of tasks or is 

a single task. 

Delete a Single Task 

Step 1. Select Operations > Scheduling > Scheduler. The Scheduler screen is displayed. 

Step 2. Right-click on the required task. 

Step 3. Click [Delete]. 

 
 

The Confirm Delete dialog box is displayed. 

 
Step 4. Click [OK]. The selected task is removed from the Scheduler screen. 
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Delete a Series of Tasks 

Step 1. Select Operations > Scheduling > Scheduler. The Scheduler screen is displayed. 

Step 2. Right-click on the required task. 

Step 3. Click [Delete]. 

 
 

The Delete a Recurring Appointment dialog box is displayed. 

 
Step 4. Select the required option. 

Option Description  

Delete only this occurrence Select this option to only delete the selected task. 

Delete the series Select this option to delete the selected task and all other 

scheduled tasks linked to this series. 

 

For example, if you schedule a task with re-occurrence rules 

(Daily, Weekly etc), by selecting this option all tasks created by 

the re-occurrence rule for the selected task will also be removed. 

 

Step 5. Click [OK]. The selected task(s) are removed from the Scheduler screen. 
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Using the Scheduler Register 
The Scheduler Register provides users with an alternative view of the Scheduler. 

The Filters 

There are a number of filters users can select to view the scheduler register in the desired format. 

Filter Description  

Task Date Select the Today option (default) to view all tasks scheduled for 

today. 

 

Alternatively, select the After or On option to view tasks 

scheduled for a particular period by entering the desired dates in 

the date fields. 

Task Type Use the Task Type filter to view selected task types in the 

schedule register. The default option is ‘All’ tasks. 

Personnel Use the Personnel filter to view tasks corresponding with 

selected personnel in the schedule register. The default option is 

‘All’ personnel. 

Home Bases Use the Home Bases filter to view tasks corresponding with 

selected bases in the schedule register. The default option is ‘All’ 

bases. 

Aircraft Use the Aircraft filter to view tasks corresponding with selected 

aircraft in the schedule register. The default option is ‘All’ aircraft. 

Allocation Status Use the Allocation Status filter to view tasks corresponding with 

a selected status in the schedule register. 

 

For example, if you are reviewing tasks which have not had 

resources assigned, you may filter out the ‘Full Allocated’ option 

and only include ‘Unallocated’ and ‘Partially Allocated’ tasks. The 

default option is ‘All’ allocation statuses. 
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In addition to the standard filters featured above, users can also apply filters based on data 

contained in custom fields. To do so, select the required custom field in the Add New Filter drop-

down list and click [Add]. 

The Columns 

There are a range of columns users can select to view in the Schedule Register. This is a personal 

setting and is maintained for each user, until further changes are made. 

Filter Description  

Task Name Select the Task Name option to view the Task Name column in 

the schedule register. 

Task Type Select the Task Type option to view the Task Type column in the 

schedule register. 

Task Start Select the Task Start option to view the Task Start column in the 

schedule register. 

Task End Select the Task End option to view the Task End column in the 

schedule register. 

Home Bases Select the Home Bases option to view the Home Bases column 

in the schedule register. 

Description Select the Description option to view the Description column in 

the schedule register. 

Resources Select the Resources option to view the Resources column in 

the schedule register. 

Status Colour Select the Status Colour option to view the Status Colour 

column in the schedule register. 

Status Select the Status option to view the Status column in the 

schedule register. 

 

 

Step 1. Select Operations > Scheduling > Schedule Register. The Schedule Register screen is 

displayed. 

Step 2. Modify the filters as required in the Filters pane. 

Step 3. Click [Apply]. 
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Printing the Schedule 
There are a number of print options available to users to print and view the schedule in the desired 

format. The print option is available on the My Schedule pane on the Home screen and in the 

Scheduler screen. 

Step 1. Select Operations > Scheduling > Scheduler. The Scheduler screen is displayed. 

 

 

Alternatively, you can access the print options by clicking the printer icon in the My 

Schedule pane on the Home screen. 

 

Step 2. Click Print [  ] in the scheduler ribbon. 

 
 

The Schedule Print Options dialog box is displayed. 
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Step 3. Select the desired print format from the Format drop-down list. 

Options Description  

Individual Schedule Report Select the Individual Schedule Report to view detailed 

scheduled task information for a selected date range. This print 

option includes the following fields: Date, Time, Task Duration, 

Task Type, Task Name, Base, Allocated Resources, Route, 

Description and any custom field values. 

Personnel Schedule Report Select the Personnel Schedule Report to view resources 

(personnel and aircraft) scheduled for tasks grouped by base 

location for a selected date range. Resources are listed vertically 

and their assigned tasks are displayed for each date. 

Task Schedule Report Select the Task Schedule Report to view resources (personnel 

and aircraft) scheduled for tasks grouped by base location for a 

selected date range. Tasks are listed vertically and their assigned 

resources are displayed for each date. 

 

Step 4. Select the required date range in the Date From and Date To fields. 

Step 5. Select the required bases from the Base drop-down list. 

Step 6. Select the applicable task types to include in the report from the Task Types drop-down 

list. 

Step 7. Click [Generate Print View]. 

 

 

To view scheduled tasks assigned to only you, proceed to Step 7 without completely 

Step 5 and Step 6. The system automatically detects all your assigned tasks for the 

selected date range. 

 


